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Document outline 

About the drawing protocol document 

Maharashtra has planned to automate the building plan approval process by introducing AutoDCR 

system. AutoDCR software reads the CAD drawings submitted by architects and automatically 

produce the deviation report based on the control regulations prescribed by Maharashtra.  

The purpose of this document is to establish a set of guidelines to Architects for preparation of 

drawings to be submitted for taking Building Permission from Maharashtra , Uniformity in the 
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process of drafting of the drawings to be submitted for approval is required for automation of 

building approval system by introducing AutoDCR system.  

The consultants/Architects should prepare the drawings keeping specific objects in specific layers 

with specific colors and text.  The layers required to be generated with explanation of what is 

required to be drawn on which layer is described in this document. This document serves as a 

source of information on obtaining level of consistency in drafting and approval process focuses 

on both the theoretical and practical description of process flow and protocol to be used while 

preparing drawings for submission at Maharashtra for Building Permission. The document 

explains use of PreDCR utility.  

 

 How to read this drawing protocol document? 

This document should be read in conjunction with the building bye-laws which will be applicable 

for approval of a proposal.  The reader of this document should have understood the applicable 

bye laws for scrutiny of a proposal. The reader should also be familiar with AutoCAD terminology 

and environment for better understanding of the system. It is more exploratory in nature than the 

specifications and contains sections to explain particular aspect of planning and designing.  

 

 

 

 

 

Drawing pre-formatting utility (PreDCR) 

 

Overview 

AutoDCR is a unique and innovative approach to automate scrutiny of building proposals by 

reading CAD drawings. AutoDCR software needs preformatted drawings with some specifications. 

PreDCR is a software application used to create the architectural plan as per AutoDCR software 

requirements. It helps in standardization of drawings and helps in reducing time required for 

preparing submission drawings. It works under AutoCAD environment with additional menu & 
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toolbar. 

 

Using PreDCR commands user can create all the required layers in one click. Once all the layers 

are created in the drawing user can use AutoCAD commands to draw entities on the 

corresponding layers with the help of PreDCR software. Short commands are provided to activate 

any layer in PreDCR. PreDCR also helps in correcting drafting errors in the drawing. At any time 

user can verify if the drawn entities are properly closed or not, if proper name text has been 

written inside all closed poly or not etc. PreDCR will highlight all the failed entities if any. 

 

 

Aims & objectives 

To bring uniformity and standardization in submission drawing format. 

To create error free drawing by auto-correction of drafting errors. 
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To Increase drafting speed and efficiency 

To reduce drawing data redundancy. 

To remove dimensioning and area calculation requirements from submission drawing format and 

auto-calculating areas in AutoDCR automatically.  

 

Salient features 

Automatically creating required layers in the drawing. 

 

 

Automatically creating and inserting entites of required size in the drawing: User can define size 

of entity and insertion point in the the drawing.PreDCR will create and insert entity in the 

drawing at specified location. 
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Automatic insertion of required text in the drawing. 

 

PreDCR can automatically insert text like room name, floor name etc. at specified location in the 

drawing. 

Drawing cleaning, refinements of poly lines, text and closed entity verification will be done by 

PreDCR to eliminate drafting errors.  
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PreDCR verify and will highlight failed entities in verifications with detailed explanation and Auto-

Zooming. 
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Benefits of PreDCR 

1) Standardization of submission drawings-Brings uniformity & standardization in submission 

drawing format. This software will correct some minor drafting errors and also provide list of 

failed entities with Auto-zooming facility so that user can easily locate the failed entities in the 

drawing.  

2) Operational ease and convenience-Data redundancy is eliminated from the drawing. Only 

minimum required entities are to be drawn in the drawing as most of the data will be auto 

detected by the system from existing available data. 

3) Increased speed and efficiency-PreDCR facilitates Auto insertion of many drawing entities like 

parking, door windows etc of required size and number. Test auto-insertion facility saves text 

typing efforts. Auto-dimensioning and auto-calculation facility saves calculation efforts. Using this 

software user can create all the required layers at one click.    

4) Accuracy - Accuracy in area calculations is achieved. Preparing Calculation tables, showing 

dimensions in the drawing is not required.  

 

Drawing formats 

 

1) Conventional submission drawing format  

 

Conventional drawing submission format 
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2) As per PreDCR format specified by PreDCR  

 

 

3) After scrutiny of drawing using AutoDCR- 
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Protocol details 

 

PreDCR is a software application used to create the architectural plan as per AutoDCR software 

requirements. It works under AutoCAD environment with additional menu & toolbar. 

           Using PreDCR commands user can create all the required layers in one click. Once all the 

layers are created in the drawing user can use AutoCAD commands to draw layout plan. 

As per AutoDCR requirement all building items like proposed plot, proposed work should be 

drawn on the corresponding layers. Short commands are provided to activate any layer in PreDCR  

At any time user can verify if the drawn entities are properly closed or not, if proper name text  

has been written inside all closed poly or not etc. PreDCR will highlight all the failed entities if any. 

          PreDCR can be used to modify/make and verify the existing or new architectural plan as per 

AutoDCR software requirements. Users are free to use AutoCAD commands and or PreDCR 

commands to achieve the main purpose which is. 

Drawing the architectural plan in DWG format as per AutoDCR software requirements. 

For automating the process of Development Control Regulations user/draughtsman/architect 

have to follow some specifications. The following are the list of specifications that the user should 

follow.  

Plot layout, detailed floor plan and building section for all the floors should be there in one AutoCAD 

drawing file.   

All building items like proposed plot, proposed work, proposed parking etc. must  be drawn 

using closed polyline. 

(i.e. Every entity must be closed LWPOLYLINE except Railway Line , Drain line, Water Line, Electric 

Line, Dead Wall and Ground lvl.). 

Building Sub-Items must be exactly inside of outer closed polygon as per their place 

in architectural plan. 

This means none of the edge or vertex of inside entity should be drawn outside its container entity.  

       For example Parking or Open Space poly must be exactly inside the main plot poly. 

       Tools are provided in PreDCR to verify this check.  

Every Building Sub-Items should be given a specific/unique name (Text or MText entity) on the same 

layer & inside the entity poly. If name not found then AutoDCR will generate the name 
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automatically. Naming Conventions should be followed properly. 

e.g.  Each Room should be given the concerned name Using <Assign Name> function of PreDCR 

Living, Kitchen, Bedroom. Etc.  

Floor Name: GROUND FLOOR; TYPICAL FLOOR 1,2 & 5-8; TERRACE FLOOR 

Floor Items: Room Names should be given properly without using abbreviations so the software 

can identify perfect entity. This can be done by Assign name facility provided by the software. 

User shall use only following kind of entities for Building Items :-  

LWPOLYLINE / TEXT / MTEXT 

If in a plan two proposed work are mirrored in that case user should provide two separate 

building plan. For each proposed work. 

 

Installation and Registration 

System Requirements 

  Pentium IV or better (or compatible processor) 

  1GB RAM 

  USB Port 

  Windows 98/2000/XP(32bit and 64bit)/Vista/Windows7(32bit and 64bit) 

  CD-ROM drive 

  AutoCAD 2000/2002/2004/2005/2006/2007/2008/2009/2010/2011. 

 

Installation 

To install PreDCR software on your computer please follow the given steps.  

Step 1:  Insert the supplied PreDCR CD in CD drive of the computer. 

Step 2:  Run the PreDCR installer by double clicking on file "PreDCR_Installer.exe"  

in the PreDCR CD. 

Step 3:  Follow the next steps in installer wizard to complete installation.  

 



 

     19                      PreDCR help Manual : Maharashtra  

 

19 Methodology 

After successful installation, a PreDCR shortcut will be placed on your computer desktop as  

shown below. 

 

Figure 1: PreDCR shortcut on desktop 

 

Methodology  

1)   Open the PreDCR software for clicking on PreDCR menu on your desktop & select the Autocad 

version & then click on "OK" button. 
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2)  First open submission drawing which is now converting in PreDCR format. 
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3)  Save as your drawing with give some name. 

 

 

4) Check the scale by using Scale command. If drawing is not in 1:100 scale then covert into the 

1:100 scale. & then make that drawing in metric scale if it is in other than meter.  
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5) Also make the site plan in 1:100 scale.  

 

  

6) By using PreDCR toolbar first select the Type of Project that is " Building Development  or  

Compound Wall/substructure “ or side plan 

a) If Plot is Already sanctioned & user have to take permission for the buildings only then 

select “Proposed Development.” 
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b) If Proposal having a only compound wall approval or only subsidiary structure approval 

without any main building then select that “Compound Wall/Substructure” option from the 

list.  

 

 

 

7)  By using PreDCR toolbar "Create a DCR layer" that is second option in PreDCR toolbar. 
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8)  Then user will get the list of PreDCR toolbar, then just click on "OK" button. Now all the Layers 

user will get in Layer Properties managers. 

 

 

Now Select current Layer is "_ Main plot" & Draw a closed polyline on this layer. Also give the plot 

name on that layer only. 
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Make the current layer “_Main Road” & Draw a road on this layer. Give the Name of road which is 

starting with it's width.  

 

 

 

Make the current Layer " …….FSI" as per your project having that use user can select that use of 

FSI. e.g. For Residential use - Select  "_ResiFSI"  poly, For Commercial use select “CommFSI” poly. 

& Draw a area key plan line on this layer. No need to give any name on this Layer. 
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Make the current Layer "_Carpet Area" and draw a closed poly on this Layer which having floor 

area excluding wall area. Also give the name on this Layer. If carpet is splitted no of places but 

having only one tenement then use the Splitted tenement option from PreDCR Mark menu bar. 

 

CARPET AREA 

Make the current Layer "_Room" and draw a closed poly on this layer. If room having rectangle 

shape then u can use rectangle also. Assign the room name for using the assigned name option 
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from PreDCR menu bar. 

 

 

 

: Insert the doors & windows by using insert option from PreDCR menu bar.  
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15)  Make the current layer "_Floor" and draw a boundary outside of each & every floor. 

  

 

 

16)  Make the current layer "_Tank" and draw U/G & O/H tank in plan as well as in section also. 

Assigned this tank name by using Assigned name option from PreDCR menubar. 

  



 

     29                      PreDCR help Manual : Maharashtra  

 

29 Methodology 

 

17) Make the current layer "_Staircase" and draw all the riser on this layer which is a open  

polyline. Also draw two extra line on this layer which is showing a floor landing and intermediate 

landing. Then mark this landing for using staircase landing option from PreDCR menu. Also mark 

the staircase which having type. For spiral and fabricated staircase no need to draw riser & 

landing marking. 
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18)  Make the current layer is "_Ground Level" and draw an open polyline on this layer which is 

place below the plinth level. 

 

 

 

Make the current layer is "_Building" and draw a boundary on this layer which is having a group 

of all the floors with section 
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Make the current layer is “_Proposed Work” and draw a total coverage on this layer. Assigned 

this proposed work by using "PreDCR->Assigned name -> Building & proposed  

Work from PreDCR menu. 

.  

If project having any Substructure then draw a closed polyline on "_Substructure" layer. Also mark 

this substructure by using " PreDCR-> Mark-> Substructure from PreDCR menu bar. 
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If project having any Existing structure then draw a closed polyline on "_Restructure" layer. Also 

mark this Restructure by using " PreDCR-> Mark-> Restructure from PreDCR menubar. 
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Mark the margins by using Mark-> margin from PreDCR menu bar 

 

 

 

After converting all the Layers use the "Fix poly" option from PreDCR menu bar.  
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Just click on "OK" 

 

Just click on "OK" 
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When u will get these message "Refinement of Polyline is done" then select the "Verify Closed 

poly" option from PreDCR menu. 

 

 

 

 

 

 

 

:  When user will get these message "Entities on PreDCR Layers are verified and found o.k." then 

only user can submit a softcopy of  your drawing to the Corporation. 
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27)   Also check the "Objection list" which user are missing to convert in PreDCR layer. 
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PreDCR Layer Information: 

 

 

_Amenity: 

Description : 

Draw Amenity space as a closed polyline which is reserve for utilities, services and conveniences. 

Shortcut Command :-AMN  

How to draw : 
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 _ArchProj: 

Description :  

- This layer is used to represent various Architectural Projections in your Plan. Draw a closed Polyline 

for Architectural Projections. And mark it using Mark->Projection from PreDCR menu, according to 

requirements. Canopy/porch will come in plot & other projections will come with floor plans. 

Shortcut Command :AP  

How to draw : - 

 

 

_Balcony 

Description :  

- Draw a balcony as a closed polyline which is a horizontal projection including parapet to serve as a 

sitting out place. Name of balcony must be inside and on _Balcony layer. 

Balcony can be present in:  

Plot: It must overlap with PWork (if not enclosed) 
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Floor: It must overlap ResiFSI 

Shortcut Command : BL   

How to draw : -   

                               

 

 

 _Building 

Description :- 

 - Building is used to group all floor plans of the same building.   Draw a closed poly enclosing all the 

floor plans and section of the same building on _Building layer. Note: As written above, dimension or 

area of this building poly has no meaning in AutoDCR. This is just an logical group of all floors of the 

same building. If the building plan of multiple Prop Works or wings are same then building name shall 

be as given in table below. 
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Building names can be. 

1  "A(Monarch)" Prop Work "A" has building 

plan "Monarch". 

2  "A,B(Monarch)" or "A&B(Monarch)" Wings A, B have same building 

plan "Monarch". 

3  "A-C(Monarch)" Wings A,B,C have same 

building plan "Monarch". 

4  "A1-A3(Monarch)" Wings A1,A2,A3 have same 

building plan "Monarch". 

 

Shortcut Command : BLD 

How to draw : 

 

 

 _Carpet area 

Description :  
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Draw carpet area as a closed polyline which is a net usable floor area within a building excluding that 

covered by the walls or any other areas specifically exempted from floor space index computation in 

these regulations. 

Shortcut command : CPT 

How to draw : -  

 

 _Chowk 

Description :  

Draw a chowk as a closed polyline which is an enclosed space permanently open to the sky within a 

building at any level. From chowk we take ventilation for habitable  rooms. 

Shortcut Command : CWK  

How to draw : 
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_Column 

Description :  

-Column shall be drawn as closed polyline on this layer. 

Shortcut Command : CPL 

How to Draw:- 
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_CommFSI 

Description:  

Draw a CommFSI as a closed polyline which is the area covered by a building on all the floors. This 

FSI polyline mainly used for commercial use bldg. 

Shortcut Command : CMFS 

   How to draw:  
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 _Compound Wall 

Description :  

Open polyline of compound wall to be drawn on proposed compound wall with text started with 

compound wall height. E.g. 1.50m. High Compound Wall 

Shortcut Command : CW 

How to draw : -  

 

_Door 

Description :  

Door is a closed Polyline which is drawn on “_Door” layer. Also you can insert a particular size poly 

for Door using Insert->Door from PreDCR menu. 

Shortcut Command : DR 
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How to draw : - 

 

 

 _Electric Line 

Description : - 

 Electric line will be present in the layout plan and shall pass through plot entity as a non closed 

polyline. 

Name electric line shall start with its voltage capacity and text insertion point shall lie on its polyline. 

  For e.g. 33 KV High Tension Line 

Shortcut Command : LI 

How to draw : - 
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 _Elevation  

Description : -  

Elevation to be drawn in _Elevation layer only for printing purpose. No regulations will bye 

checked by reading this layer. The drawing on this layer need not be drawn using polylines  

Shoutcut :-  

How to draw :- 
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_EWS 

Description: -  

Draw a EWS area on “_EWS” as a closed poly line, which area is left for economically weaker 

section.  

How to draw :- 

Draw a closed poly line on _EWS layer in floor plan. 

 

_ExStructure:- 

Description: - Draw an Exstructure as a closed polyline which is a building or structure existing 

authorized before the commencement of these regulation. And mark it using Mark -> Existing 

structure as 'To be demolished' or 'to be retained’. 

Shortcut Command : EX 

How to draw :-   
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 _Floor 

Discription: 

Draw a Floor as a closed polyline to the boundary of the lower surface in a story on which one 

normally walk in a building and including mezzanine floor also. The floor at ground level with a direct 

access to a street or open space shall be called the ground floor, the floor above it shall be termed as 

Floor 1 with the next higher floor being termed as Floor 2 and so on upward. For giving the name of 

each floor use the assign named option from the PreDCR menu. Also draw each floor separately. 

While giving name to the typical floor then use a Typical option from Assigned name -> Floor name 

option from PreDCR menu bar. 

Shortcut Command : FLR 

Reference Circle: - All Floor poly must contain a circle with its center on common point for whole 

building on layer "_ResiFSI". Usually it can be placed inside either Common Liftwell or stair/Inner 

Chowk as their locations are common for all floors. 

Floor Name: - Floor name will be taken from text inside floor poly and on same layer. 

  A floor plan is automatically associated/linked by AutoDCR software with one or more floor section 

poly in Section plan. This is done by matching name of Floor Plan and FloorInSection so both must be 

same. 

Typical Floor Non-Typical 

"TYPICAL" X "FLOOR PLAN"X: Floor numbers 

in specific format (, or & or -) 

X "FLOOR PLAN" 

X: Direct Floor's Name 

e.g.: 

TYPICAL 1,2 FLOOR PLAN 

TYPICAL 1-4 FLOOR PLAN 

TYPICAL 2&3 FLOOR PLAN 

e.g. 

GROUND FLOOR PLAN 

FIRST FLOOR PLAN 

SECOND FLOOR PLAN 
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How to draw :- 

 

 

 

 _FloorInSection :  

Description :  

Draw a FloorInSection polyline as a closed poly of section boundary which contain all floors with stair 

cabin, Liftwell machine room, water tanks etc. as shown in the figure. Also write the name as 

"Section" in this section poly. 
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In this closed poly of section draw sections of all floors with stair cabin, inner Chowk, Liftwell 

machine room, Ventilation shaft, water tanks etc. as shown in the figure. 

Also write the name as "Section" in this section poly. 

This section poly will present inside the building poly. 

Shortcut Command : SEC 

How to draw : - 

 

 

 _Ground Level 

Description :-  

Draw the Ground level line as open polyline in section .It is used for checking a total building height 

from this line. 
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Shortcut Command : GL 

How to draw : - 

 

_IndFSI 

Description :-  

Draw a IndFSI as a closed polyline (area key plan line in the submission drawing) which is the area 

covered by all the floors. Industrial building means building or part thereof wherein products or 

material are fabricated, assembled or processed such as assembly plants, laboratories, power plans, 

refineries, gas plants, mills, dairies and factories. This polyline should be excluding balcony & terraces 

area. 

Shortcut Command :IFSI 

How to draw : -      
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_Internal Road 

Description :  

Draw internal road with text specifying its width as shown in figure. And draw a center line. And type 

of layer of the center line must be center line (Type of the Layer). 

Shortcut Command : R2 

How to draw : - 
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 _Lift well  

Description :  

Draw a Liftwell as a closed polyline which is a mechanically guided car, platform or transport for 

persons and materials between two or more levels in a vertical or substantially vertical direction. If fire 

Liftwell is provided then use the marking of “Fire Liftwell" option from Mark -> Liftwell -> Fire 

Liftwell. Fire Liftwell means a special Liftwell designed for the use of fire service personnel in the 

event of fire or other emergency. 

Shortcut Command : LFT 

How to draw :  
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Layer: _LIG 

Description :  

Draw LIG area in _LIG layer as close poly line which is left for Lower Income Group. 

How to draw :  
Draw closed ply line,It should be Inside of Floor or Plot. 
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_Location Plan 

Description :  

Locations plan if any to be drawn on this layer. This is only for reference. No verifications are done by    

AutoDCR for this layer so not compulsory. 

Shortcut Command : LCP 

 

 _Main Plot 

Description: 

Draw a Plot poly as a closed polyline which is a parcel or piece of land enclosed by definite 

boundaries. A Plot will contain all Proposed Works (buildings, wings), open space, Internal Roads, 

Parking etc. The overall Plot Entity represent a Plan, AutoDCR refers it as 'Layout Plan'. The overall 

Plot Entity represent a Plan, AutoDCR refer it as "Layout Plan". 

Shortcut Command: PLT 

How to draw : 
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_ Main Road 

Description : 

Draw a Main Road as a closed polyline which is abutting the plot. On the site that road is any type of 

road. Such as any highway, street, lane, etc. over which the public have a right of passage or access or 

have passed and had access uninterruptedly for a specified period, whether existing or proposed in any 

scheme. Road name start with its width only. 

Shortcut Command : R1 

How to draw : - 
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 _Margin Line 

Description :  

No need to draw Margin Line, Just use Mark Margin tool for it. This layer is not provided for users. 

AutoDCR uses '_Margin Line' layer for it's own internal use. 

 

 _NETPLOT 

Description :  

No need to draw NETPLOT. This layer is not provided for users. AutoDCR uses '_NETPLOT ' layer 

for its own internal use. 
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NotInPossission :  

Description :  

Plot area which is not in possession or which is not in proposal to be drawn as a closed polyline 

on this layer. 

Shortcut Command: NIP 

How to draw : - 

  

_Parking 

Description :  

Draw a parking poly as a closed polyline which is an enclosed covered or open area sufficient in size 

to park vehicles. This closed polyline shall contain a text on same _Parking layer. This text is treated 

as name of parking. Insert the parking by using a Insert-> Parking option. 

Shortcut Command : PK 
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Parking Name : 

This closed polyline shall contain a text on same _Parking layer. This text is treated as name of 

parking. 

  On this layer, you can group and insert any number of parking 

Parking Name 

Car                     (2.75 X 5.0) CP 

Scooter              (1.50 X 0.84) SC 

Cycle                 (1.50 X 0.70) CY 

How to draw : - 

 

_Passage 

Description :  
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A closed polyline on _Passage represents a passage. It is a common passage or circulation space 

including a common entrance hall. This closed polyline contain a text. This text must be on "_Passage" 

layer. This text is treated as name of closed polyline. 

 

Centre Line: - All Passage poly must contain an Open Polyline inside that closed poly representing 

centre  line on "_Passage" Layer. But line type of center line must be 'Center line'. 

Shortcut Command :PAS  

How to draw:-  
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_PlotSurroundingDetails: 

Description :  

A closed polyline on “_PlotSurroundingDetails” layer represents surrounding details of plot.  

 

_ PrintAdditionalDetail:- 

Description:-  

PrintAdditionalDetail layer----Apart from the layers specified by PreDCR, any other information 

which user wants to display in final approval print shall be drawn on _PrintAdditionalDetail layer.  

Shortcut Command:- 

How to draw:- 

 

   

_Podium 

Description :  

Podium shall be drawn on '_Podium' layer as a closed polyline. Podium should be inside plot covering 

proposed works if any. 

Shortcut Command: -POD  

How to draw :- 
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_PropWork 

Description :  

Proposed Work is a building profile/outline and shall be drawn inside plot. All detail Building plans 

(inside building polyline) of all PWork (inside plot polyline) is associated/linked automatically by 

Auto-DCR by matching its name. 

  So for proper association it is required to follow specific standard as given. 

  XY (Z) 

  X is Wing name. 

  Y is wing number. 

  Z is Building name. 
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For example if there are four wings A1,A2 & B1,B2 in building named "Monarch" then proposed 

work  names shall be - 

  A1 (Monarch), A2 (Monarch) 

  B1 (Monarch), B2 (Monarch) 

Reference Circle: All PWork poly must contain two circles (of any size) with its center on common 

point for whole building. First on layer of any FSI and second on Layer “_Floor”. These reference 

circles to be inserted from PreDCR -> insert-->Direction ref circles at the same location in all the 

floors as well as pwork in plot.  Usually they can be placed inside either Common Liftwell or 

Stair/Inner Chowk (because generally their location is same on all floors). Reference circles are used 

by the software for overlapping all floor plans. 

Shortcut Command:- PW 

How to draw :- 

 

_Ramp 

Description :  
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Draw a Ramp poly as a closed polyline in floor plans and/or plot and section. Naming convention for 

ramp is "---m. long and ---m. high ramp-1". Give unique name to each ramp. 

Shortcut Command :-RP  

How to draw : - 

 

_Recreational Ground 

Description :  

 Draw Recreational Ground as closed polyline reserved as recreational space on this layer. With text on 

same layer. 

Shortcut Command: -OPS 

How to draw :- 
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_Refuge Area 

Description :  

Refuse area to be drawn in plan as a closed polyline with text on this layer. Overlapped with FSI layer 

but outside the FSI poly. 

Shortcut Command : RFG 

How to draw :  
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_Refuge Chute 

Description :  

Shortcut Command : RFG 

How to draw :  

Draw closed poly line. 

 

_ResiFSI 

Description : - 

Draw a ResiFSI as a closed polyline which is the area covered by a building on all the floors. This FSI 

polyline only used for residential use building or floor. ResiFSI poly must be inside Floor poly. 
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Shortcut Command : MFS 

How to draw :- 

      

 

 

 

_Road Widening 

Description :  

Draw a road widening polyline as a closed polyline which the plot area is going to the road, that area   

should be drawn on this layer. It should be inside the plot polyline. 
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Shortcut Command : R5 

How to draw : - 

 

_Room 

Description :  

A closed polyline on _Room layer represents a room. This closed polyline contain a text. This text 

must be on _Room layer. Room to be marked by assigning them names using Assign Name-> room 

option from PreDCR menu. 

Shortcut Command : RU 

How to draw : - 
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_Right-of-Way  

Description :   

Draw a closed polyline on “_RightOfWay” to represent a Right Of way and text inside it 

representing its width. Layer should be inside or intersecting with Plot poly 

Shortcut Command : ROW 

How to draw : - 
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_Section 

Description :  

Draw a Section polyline as a closed poly of section boundary which contain all floors with stair cabin, 

Liftwell machine room, water tanks etc. as shown in the figure. Also write the name as "Section" in 

this section poly. 

In this closed poly of section draw sections of all floors with stair cabin, inner Chowk, Liftwell 

machine room, Ventilation shaft, water tanks etc. as shown in the figure. 

Also write the name as "Section" in this section poly. 

This section poly will present inside the building poly. 

Shortcut Command : SEC 

How to draw :  
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_Section Line 

Description: -  

Draw a section line on “_SectionLine” layer to represent building section. 
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_Sewage Line 

Description: -  

Drain Line shall be drawn as a open polyline on this layer. 

Shortcut Command : L5 

How to draw : -  
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 _SpecialUseFSI 

Description :- 

FSI ploy for all other building uses like educational, institutional etc. except ResiFSI, CommFSI & 

IndFSI use should be drawn on this layer. 

Shortcut Command : SUF 

How to draw : - 
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 _Staircase 

Description :  

Staircase: On this layer, Each Staircase poly shall have three lines for Flight Width, Intermediate 

Landing and Floor Landing on same layer. Mark these open polyline by using Mark-> Staircase 

option from PreDCR menu. Also draw in plan all the treads on this layer which is a open polyline. 

This closed polyline contains a text. This text must be on _Stair layer. This text is treated as name of 

closed polyline. On this layer, Each Staircase poly shall have three lines for Flight Width, Intermediate 



 

     75                      PreDCR help Manual : Maharashtra  

 

75  

Landing and Floor Landing on same layer This can be mark by tool Mark > Staircase > intermediate 

landing etc. 

Shortcut Command : STR 

How to draw : - 

 

 

 

_Substructure 

Description :  

Draw various substructures on "_Substructure" layer as a closed polyline. And mark it according to the 

requirement as Mark -> Substructure -> Society Office, from PreDCR menu. Sub-structures can be 

drawn inside plot or in floor plans. 

Shortcut Command : SSTR 

How to draw :  
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_Tank 

Description :  

A closed polyline on _Tank layer represents a water tank. Under Ground tank can be drawn in Floor or 

Layout plan. If it is drawn in Floor plan then it should be at bottom of GROUND FLOOR. Overhead 

tank can be drawn in TERRACE FLOOR. Tank should be drawn as per internal size or dimensions. 

Both the tank also draw in section also. 

Tank Name: - This closed polyline contain a text and must be in given format. This can also be done 

by tool Assign Name>Tank 

  Tank Name+ Type +Capacity 

Tank Type Text 

Overhead water tank (O/H) 

Underground water 

tank 

(U/G) 
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  For e.g. 

  TANK-1 (O/H) 

  TANK-2 (U/G) 

Under Ground tank can be drawn in Floor or Layout plan. If it is drawn in Floor plan then it should be 

at bottom of GROUND FLOOR. 

Overhead tank can be drawn in TERRACE FLOOR. Usually it is drawn on Staircase poly in 

TERRACE FLOOR. 

Shortcut Command : TNK 

How to draw : - 

 

  

 

 

_Terrace 

Description:-  
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Draw a Terrace as a closed polyline on _Terrace layer which is including parapet wall. 

Terrace can be present in:  

 Plot: It must overlap with PWork 

 Floor: It must be outside the ResiFSI. 

Shortcut Command : TER 

How to draw : - 
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_Tree 

Description :  

Trees can be shown on _Tree layer if required to be shown for plantation requirement in plot. 

Shortcut Command  : TRE 

How to draw :   

Insert Tree from PreDCR options. 

 

_Ventilation Shaft 

Description :  

Draw Ventilation shaft/duct area as a closed Polyline with Text. Inside FSI Area on _VentiShaft Layer. 

Only those shafts from which ventilation for habitable room is not taken should be drawn on this layer. 

Shortcut Command:-AVS  

How to draw : -         



 

     80                      PreDCR help Manual : Maharashtra  

 

80  

 

 

 _Void 

Description : 

If the space is not Chowk then it can be void. All ducts (where ventilation is not taken) and double 

height rooms can be drawn in void layer. 

Shortcut Command  : VD 

How to draw :  
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_WaterLine 

Description :  

Draw a Water line as a open polyline to show Water supply. 

Shortcut Command : WL 

How to draw : - 
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_Window 

Description :  

Window is a closed Polyline which is drawn on "_Window" layer. Also you can insert a particular size 

poly for Window using Insert->Window from PreDCR menu. 

Shortcut Command : WND 

How to draw : - 
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Tools  

All/Remover Tool Tip ( PDCRTOOLTIP ): 

This command will activate the tool tips for PreDCR layers. 

 

Show Only DCR Layers: 

All PreDCR layers (PDCRSPL): 

This command will turn off all the layers in the drawing except PreDCR layers.  

 

Building level layer (PDCRSBL): 

 

 This command will turn on all the building plan level layers in the drawing. 

 

Layout level layer (PDCRSLL): 

 

This command will turn on all the Layout plan level layers in the drawing. 

 

Show Only DCR Layers (PDCRSDL): 

 

This command will turn off all the layers in the drawing except DCR layers.  
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Show Other Layers (PDCRSOL): 

 

This command will turn off all the DCR and PreDCR layers in the drawing. 

 

Show All layers (PDCRSAL); 

 

 This command will turn on all layers in the drawing. 

 

Calculate Total Area (PDCRCTA): 

 

This command will compute the total area of all selected closed polygons. 

 

 

Calculate Deducted Area (PDCRCDA): 

 

This command will compute the area of closed polygon after deducting closed polygons found 

inside. 
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Get All Inside Poly (PDCRFIP):  

 

This command will highlight all polygons, which found exactly inside selected polygon under test. 

  

Get All Overlapping Poly (PDCRGOP): 

 

This command will highlight all polygons, which are overlapping with selected polygon under test. 

  

Get All Intersecting Poly (PDCRGIP): 

 

This command will highlight all polygons, which are intersecting with selected polygon under 

test. 

  

Find Open Entities (PDCRFNDO):  

 

Highlight open entities on PreDCR layers. 

 

Find Closed Entities (PDCRFNDC):  

 

Highlight closed entities on PreDCR layer. 

 

Shortest distance (PDCRFSD):  

 

This command will find the shortest distance between two entities. 

 

Spelling check (_spell):  

 

This tool is used for spelling checking. 

 

Find Object (PDCRFOBJ):  
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This command zoom & highlight object of a given handle. 

 

Set Default ACAD Version (PDCRSDA



87 

 

Commands 

Create New Project (PDCRNWP) 

This command will Create New project for current drawing. 

Here you have to select Type of Project as  

 Proposed Building Development. 

 

Note: It is always compulsory to add your drawing to new Project. 

 

Create AutoDCR Layers (PDCRCL):  

This command will create layers required for AutoDCR and as per the Project Type you have 

selected. 

Fix Poly (PDCRPE):  

 

Use this command once on the final drawing which will process all the polyline on the PreDCR 

layer and remove extra vertices found on polyline. This command can be used before verifying 

the drawing using Verify commands. 

 

Verify Drawing:  
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This command will verify the current drawing as required by DCR specifications. 

 a) Verify Close Entities (PDCRVD): Verify that LWPOLYLINE entities on the selected layers are 

closed and contain one text. 

 

B) Verify all drawing (PDCRVT): Use this command to verify the layout and building level 

objects in the current drawing plan.  

Major checks are as follows: 
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In the "Verify All Drawing Dialog" you can select the layout or building objects to be checked. 

Then to view the result press OK button. PreDCR will start checking all corresponding objects in 

the currently open drawing and then display the status as OK or list of failed objects in the dialog 

as shown in Figure. Failed Object Information.  

Check if these entities are drawn as closed LWPOLYLINE. 

Name text is given to all objects. 

Entities are placed exactly inside their parent objects (container). 

Naming conventions are followed properly. 

c) Objection List (PDCROLST): This command gives the list of all minimum required entities 

which are not there in your drawing. If all required entities found then it gives a message that 

“minimum required entities are present in drawing”. 

 

 Markings 

 

Marking adds some extra meaning in entity. Following commands are provided to mark different   

entities as per requirement.  

Mark-> Proposed work-> Centrally Air conditioned : Mark proposed work as centrally air 

conditioned if it is. 
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Mark-> Proposed work -> Normal( Default):Mark proposed work as normal. 

Mark-> Floor in section-> Beam: In beam is present in floor so user can mark beam eith the help 

of this marking option. 

Mark-> Floor in section->Normal ( Default): Mark floor as a floor in section. 

Mark-> Stair Case-> No of flight -> 3flight or 4flight (PDCRSCFAB): Mark line inside staircase 

as a no of flight 3flight 4flight 

Mark-> Stair Case->Staircase {Default} (PDCRSCFAB): Mark line inside staircase as a Staircase 

{Default}  

Mark-> Stair Case->Open Staircase (PDCRSCFAB): Mark line inside staircase as a open staircase 

Mark-> Stair Case->Fire Escape Staircase (PDCRSCFAB): Mark line inside staircase as a fire 

escape staircase. 

Mark-> Stair Case-> Fab /Spiral Staircase (PDCRSCFAB): Mark line inside staircase as a 

Fabricated or spiral staircase.  

Mark->Escalators (PDCRMFL): Mark ->Escalators as a provided 

     Mark->Staircase Landing ->Intermediate Landing (PDCRMIL): Mark line inside staircase as 

intermediate Landing.  

Mark->Stair Case Landing->Flight Width (PDCRMFW): Mark line inside staircase as Flight 

Width. 

Mark->Stair Case Landing->Floor Landing (PDCRMFL): Mark line inside staircase as Floor 

Landing.  

2) Mark-> Lift- -> Lift {Default} (PDCRSCES):- mark-> Lift-> as a lift {Default} 

    Mark-> Lift- -> Hydraulic (PDCRSCES):- mark-> Lift-> as a Hydraulic  

    Mark-> Lift-> Fire Lift -> (PDCRSCES): mark->Lift -> as a Fire Lift  

Mark->Ramp->Ramp for Handicapped: mark ramp as a ramp for handicapped if that ramp for 

handicapped people. 

Mark->Ramp-> Unmark (default): Mark ramp as a normal ramp. 

Mark->FSI-> Existing FSI (PDCRCONES): Mark Residential or Commercial FSI as Existing FSI. 

Mark->FSI->Normal (Default) (PDCRUMFSI): Mark Residential or Commercial FSI as Normal 

FSI. 

 

Mark->Carpet Area->Splitted Tenement (PDCRMSPLTT): Mark Carpet Area as Splitted 
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tenement. 

Mark->Carpet Area-> SlumDevopment->sale or rehab (PDCRUMFSI): Mark Carpet Area as a 

slumdevlopment sale or rehab Normal 

Mark->Carpet Area->Normal (default) (PDCRMSPLTT): Mark Carpet Area as Normal (default)   

Mark -> Parking-> Two Stacked: Mark parking poly as a two stacked. 

Mark -> Parking-> Three Stacked: Mark parking poly as a three stacked. 

Mark -> Parking-> Four Stacked: Mark parking poly as a four stacked. 

Mark->Projection-- > 

Mark->Projection->Chhajja (PDCRMCJPROJ): Mark Projection as Chajja.  

Mark->Projection->Loft (PDCRMLPROJ): Mark Projection as Loft in floor plan as well as in 

section.  

Mark->Projection->Canopy (PDCRMCBPROJ): Mark Projection as Canopy.     

Mark->Projection->Porch   (PDCRMCPROJ): Mark Projection as Porch.    

Mark->Projection->Verandah (PDCRMVPROJ): Mark Projection as a Verandah. 

Mark->Projection-> Otta (PDCRUMPROJ): Mark Projection as a Otta as a provided.  

Mark->Projection-> Steps (PDCRUMPROJ): Mark Projection as a Steps as a provided.  

Mark->Existing Structure ->To Be Retained ->Building or Substructure (PDCRMREXWD): 

Mark Existing structure as to be Retained Building or Substructure. 

Mark->Existing Structure-> to be demolish (Default) (PDCRMRMREXWC): Mark Existing 

structure as to be Demolish. 

Mark->Substructure-> Electric Meter Room (PDCRMER): Mark Substructure as an Electric 

meter room. 

Mark->Substructure->Electric Sub-Station   (PDCRMTRAN): Mark Sub Structure as an electric 

Sum-Station. 

Mark->Substructure->Watchman Cabin   (PDCRMTRAN): Mark Sub Structure as an watchman 

cabin  

Mark->Substructure->Society Office (PDCRMOR): Mark Sub Structure as a Society office. 

Mark->Substructure->Servant Quarter (PDCRMSQ): Mark Sub Structure as a servant quarter. 

Mark->Substructure->Sanitary Block (PDCRMSB): Mark Sub Structure as a sanitary block. 

Mark->Substructure -> Covered Garage (PDCRMGRJ): Mark Sub Structure as a covered garage 

when garage is covered. 
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Mark->Substructure -> Rain Water harvesting (PDCRMGRJ): Mark Sub Structure as a Rain 

Water harvesting.  

Mark->Substructure -> A.C Plant Room (PDCRMGRJ): Mark Sub Structure as a A.C Plant Room 

Mark->Substructure -> AHU (PDCRMGRJ): Mark Sub Structure as a AHU 

Mark->Substructure -> Swimming Pool (PDCRMGRJ): Mark Sub Structure as a Swimming Pool  

Mark->Substructure -> Septic Tank/Soak pit (PDCRMGRJ): Mark Sub Structure as a Septic 

Tank/Soak pit   

Mark->Substructure ->Pump House (PDCRMPR): Mark Sub Structure as a Pump House. 

Mark->Substructure ->Effluent Treatment Plant/ STP (PDCRMETP): Mark Sub Structure as a 

Effluent Treatment Plant /STP 

Mark->Substructure ->Dish Antenna room (PDCRMSPT): Mark Sub Structure as a Dish 

Antenna room  

Mark->Substructure -> Well (PDCRMSPT): Mark Sub Structure as a Will  

Mark->Substructure ->Telephone Installation room (PDCRMSPT): Mark Sub Structure as a 

Telephone Installation room  

Mark->Substructure -> Entrance gate (PDCRMSPT): Mark Sub Structure as a Entrance gate 

Mark->Substructure -> Fitness center (PDCRMSPT): Mark Sub Structure as a Fitness center  

Mark->Substructure -> Suction Tank (PDCRMSPT): Mark Sub Structure as a Suction tank 

Mark->Substructure -> Pavilion (PDCRMSPT): Mark Sub Structure as a Pavilion  

Mark->Substructure -> Gymnasium (PDCRMSPT): Mark Sub Structure as a Gymnasium  

Mark->Substructure -> Club-House (PDCRMSPT): Mark Sub Structure as a Club-House  

Mark->Substructure -> Dust bin (PDCRMSPT): Mark Sub Structure as a Dust bin 

Mark->Substructure -> Milk/ Telephone booth->    (PDCRMSPT): Mark Sub Structure as a 

Milk/   Telephone booth.     

Mark->Substructure -> Letter Box (PDCRMSPT): Mark Sub Structure as a Letter Box.  

Mark->Substructure -> Chimney (PDCRMSPT): Mark Sub Structure as a Letter Box. 

 

 

 

Mark->Substructure -> Storage : Mark Sub Structure as a storage. 

Mark->Substructure -> Godown : Mark Sub Structure as a godown. 
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Mark->Special use FSI ->  

 Education. 

 Institutional 

 Assembly 

 Public/Semi-Public 

 Recreational 

 Transport 

                 

Mark->Margin (PDCRMRGN): Use this command to define or mark the front, sides and rear 

margins of the plot. . 

 

 

Insert entities 

Insert->Parking-> Car/ Motor Vehicle  (2.5m. X 5.0m.) ((PDCRICP) -> Use this command to 

insert car-parking poly of. at selected point.  

Insert-> Parking-> Scooter/ Motor Cycle    (1.0m. X 2.0m.) (PDCRISP) ->Use this command to 

insert Scooter parking poly at selected point. 

Insert-> Parking-> Transport Vehicle/ Ambulance / Mini Bus (3.75m. X 7.5m.) (PDCRICY) -

>Use this command to insert Cycle parking poly at selected point.  

 Insert->Door (PDCRIDRNAM): Use this command to insert door poly at selected point and with 

specified size given by user. As soon as you use this command the following Dialog appears.   
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8. Insert->Window (PDCRIWNDNAM): Use this command to insert window poly at selected 

point and with specified size given by user. 

 

9. Insert->Common Reference Circle (PDCRIWC): Use this command to insert direction 

reference circle. Insert these circles in all the floor plans as well as in proposed work at the same 

& common place (e.g. Liftwell or Stair) of all the floors. 

10. Insert->Direction Reference Circle (PDCRIWC): Use this command to insert direction 

reference circle. Insert these circles in all the floor plans as well as in proposed work at the same 

& common place (e.g. Liftwell or Stair) of all the floors. 

11.Insert  Tree (PDCRINTR): Use this command to insert Tree. Insert Trees showing location 

of Trees in your plot.  

12. Insert->North Direction (PDCRINND): Use this command to insert North Direction. Insert 

North Direction indicating the sides of your plot. You have to rotate this as per North Side.  

13.Insert-> Stair UP/DN Direction : Use this command to insert Staircase UP and Staircase 

DOWN direction. UP and DN direction indicating the flight direction of your staircase.  
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Assign Name 

- There are few naming conventions required by AutoDCR, for which PreDCR provides the 

following tools: 

Assign Name->Building and proposed works (PDCRBLDPWNL): Use this command to give 

name for building poly and its associated proposed works. 

 

Assign Name->Tank (PDCRTNKNAM): Use this command to give name for Tank poly and its 

corresponding tanks. 

 

Fill in the dialog and select the tank poly drawn in plan and the same drawn in section 

Assign Name->Room (PDCRASRUN): Use this command to give different names for Room poly. 
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Assign Name->Floor Name (PDCRASFLRNAM): Use this command for assigning name to a floor 

poly and it’s corresponding  floor in section poly in section. 
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Tools  

Show Only DCR Layers: 

All PreDCR layers (PDCRSPL): 

This command will turn off all the layers in the drawing except PreDCR layers.  

Building level layer (PDCRSBL): 

 This command will turn on all the building plan level layers in the drawing. 

Layout level layer (PDCRSLL): This command will turn on all the Layout plan level layers in the 
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drawing. 

Show Only DCR Layers (PDCRSDL): 

This command will turn off all the layers in the drawing except DCR layers.  

  

Show Other Layers (PDCRSOL): 

This command will turn off all the DCR and PreDCR layers in the drawing. 

 

Show all layers (PDCRSAL); 

 this command will turn on all layers in the drawing. 

 

Calculate Total Area (PDCRCTA): 

This command will compute the total area of all selected closed polygons. 

 

 

Calculate Deducted Area (PDCRCDA): 

This command will compute the area of closed polygon after deducting closed polygons found 

inside. 

           

Get All Inside Poly (PDCRFIP):  

This command will highlight all polygons, which found exactly inside selected polygon under 
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test. 

  

Get All Overlapping Poly (PDCRGOP): 

This command will highlight all polygons, which are overlapping with selected polygon under 

test. 

  

Get All Intersecting Poly (PDCRGIP):  

This command will highlight all polygons, which are intersecting with selected polygon under 

test. 

  

Find Open Entities (PDCRFNDO): Highlight open entities on PreDCR layers. 

 

Find Closed Entities (PDCRFNDC): Highlight closed entities on PreDCR layer. 

 

Shortest distance (PDCRFSD):  This command will find the shortest distance between two 

entities. 

 

Convert ARC into Polyline (PDCRFSD):  This command will convert ARC into Polyline.  

 

Spelling check (_spell): This tool is used for spelling checking. 

 

Find Object (PDCRFOBJ): This command zoom & highlight object of a given handle. 

 

Set Default ACAD Version (PDCRSDA): 

 

 

PREDCR SHORT-CUT COMMANDS 

Layer name Description 

 

Naming Convention short 

command 
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_Amenity Draw Amenity space as a closed 

polyline which is reserve for 

utilities, services and 

conveniences. 

 AMN 

_ArchProj This layer is used to represent 

various Architectural Projections 

in your Plan. Draw a closed 

Polyline for Architectural 

Projections. And mark it using 

Mark->Projection from PreDCR 

menu, according to requirements. 

Canopy/porch will come in plot & 

other projections will come with 

floor plans. 

 

Mark -> Projections -> 

Chajja 

 

AP 

_Balcony Draw a balcony as a closed 

polyline which is a horizontal 

projection including parapet to 

serve as a sitting out place. Name 

of balcony must be inside and on 

_Balcony layer. 

 

 

If Balcony is Enclosed 

Than 

Mark -> Balcony -> 

Enclosed Balcony 

 

BL 
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_Building Building is used to group all floor 

plans of the same building.   Draw 

a closed poly enclosing all the 

floor plans and section of the 

same building on _Building layer. 

Note: As written above, 

dimension or area of this building 

poly has no meaning in AutoDCR. 

This is just an logical group of all 

floors of the same building. If the 

building plans of multiple PWorks 

or wings are same then building 

name shall be as given aside. 

 

 

Naming Convention 

will be  

provided by 

Tool>Assign Name 

A (Bldg.Name) inside 

Bldg.Poly & 

A-1 (Bldg.Name) 

inside Pwork Poly 

BLD 

 

_Carpet area 

Draw carpet area as a closed 

polyline which is a net usable 

floor area within a building 

excluding that covered by the 

walls or any other areas 

specifically exempted from floor 

space index computation in these 

regulations. 

 

If Carpet area is 

Splitted – Tenement. 

Mark-> Carpet area-> 

normal (default) 

 

CPT 

 _Chowk Draw a chowk as a closed polyline 

which is an enclosed space 

permanently open to the sky 

within a building at any level. 

From chowk we take ventilation 

for habitual rooms 

 CWK 

_CommFSI Draw a CommFSI as a closed  CMFS 
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polyline which is the area 

covered by a building on all the 

floors. This FSI polyline mainly 

used for commercial use bldg. 

No need to give name 

on this layer. 

_Compound Wall Closed polyline of compound wall 

to be drawn on this layer 

overlapping plot.  

 

 

1.5m high compound 

wall 

CW 

_Door    

Door is a closed Polyline Which is 

drawn on “_Door” layer. Also you 

can insert a particular size poly 

for Door using Insert->Door from 

PreDCR menu. 

 

 

Insert-> Door 

DR 

_Elect line 

 

 

 

 

Electric line will be present in the 

layout plan and shall pass through 

plot entity as a non closed 

polyline. 

   Name electric line shall start 

with its voltage capacity and text 

insertion point shall lie on its 

polyline. 

 

 

33 KV High Tension 

Line 

L1 

_Elevation  Description:- Elevation to be 

drawn in _Elevation layer only for 

printing purpose. No regulations 

will be checked by reading this 

layer. The drawing on this layer 

need not be drawn using 

 EL 
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polylines.  

_EWS Description: - Draw a EWS area 

on “_EWS” as a closed poly line, 

which area is left for 

economically weaker section.  

 

  

_ExStructure Draw an Exstructure as a closed 

polyline which is a building or 

structure existing authorized 

before the commencement of 

these regulation. And mark it 

using Mark -> Existing structure 

as 'To be demolished' or 'To be 

retained’. 

 

 

Mark-> Existing 

Structure-> To be 

Demolished    OR   

To be Retained       

ES 

_FloorInSection  Description: - Draw a Floor 

Inspection as a closed polyline 

which is the height of that floor 

(slab top to slab top) This poly 

only used for checking floor 

height. For assigning the name of 

FloorInSection then used 

Assigned name option for 

PreDCR tool menu. 

  Name of each floor section will 

be same as of floor in plan. 

  For one typical floor plan 

multiple floor section will be 

there. 

 SECF 
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For e.g. for one typical floor plan 

for 1-3 floors there will three 

sections shall be drawn with 

name "First Floor Plan", "Second 

Floor Plan" and "Third Floor 

Plan" respectively. 

  

_Floor Floor poly should be drawn as a 

closed Polyline with Text on same 

Layer. This is just a logical Group 

of all floor Entities. 

           Floor Name: Floor Plan will 

be automatically link with Section 

by matching the Floor Name. 

Hence all names to be given using 

<Assign Name> function 

Naming Convention 

will be  

provided by 

Tool>Assign 

Name>Floor name 

 

Name of  floor should 

be in given format: 

TYPICAL-1,4 FLOOR 

PLAN 

TYPICAL-1-5 FLOOR 

PLAN 

TYPICAL-2&3 FLOOR 

PLAN 

Ground Floor Plan 

FLR 

_Ground Level  The Ground level line should be 

drawn as an open polyline in the 

section poly. 

Prop.Ht. will be considered from 

GroundLevel Polyline 

 

 

No need to give name 

on this layer. 

  

GL  
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_IndFSI   Draw a closed FSI Polyline, 

which is used as a Industrial 

Purpose. 

  

No need to give 

Name on this layer.  

 

IFSI 

_Internal Road 

 

Draw each Internal Road as a 

closed Polyline with Centre Line 

(Ltype-CentreLine) & single text 

inside it. 

 

 

7.50 m wd. Internal 

Road 

R2 

_Liftwell 

 

Draw a Liftwell as a closed 

polyline which is a mechanically 

guided car, platform or transport 

for persons and materials 

between two or more levels in a 

vertical or substantially vertical 

direction 

 Fire Liftwell means a special 

Liftwell designed for the use of 

fire service personnel in the 

event of fire or other emergency. 

 

Naming Convention 

will be  

provided by 

Tool<Mark>Lift 

 

If Hydraulic Lift 

option from Mark -

>Hydraulic  

 

Lift" option from 

Mark -> Lift -> Fire 

Lift. 

 

LFT 

_LIG Description :  

Draw LIG area in _LIG layer as 
close poly line which is left for 
Lower Income Group. 
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_Location plan 

 

Location plans if any to be drawn 

on this layer. This is only for 

reference. No verifications are 

done by AutoDCR for this layer so 

not compulsory. 

 

 LCP 

_Margin line Margin Polylines will be created 

by PreDCR by using Tool 

"Mark>Margins" 

(User need not do anything on 

this layer.) 

 

 L3 

_Main Plot 

 

Description: - Draw a MainPlot 

poly as a closed polyline which is 

a parcel or piece of land enclosed 

by definite boundaries. A MainPlot 

will contain all Proposed Works 

(buildings, wings), open space, 

Internal Roads, Parking etc. The 

overall MainPlot Entity represent 

a Plan, AutoDCR refers it as 

'Layout Plan'. The overall 

MainPlot Entity represent a Plan, 

AutoDCR refer it as "Layout 

Plan".  

 PLT 

_Main Road 

 

 

Draw Main Road as a closed Poly 

with Text, which should be 

abutting with the Plot closed Poly. 

(Note: Road width must be 

written at the starting of Text) 

 

24.00 m wd. Main 

Road 

R1 
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_Nala Draw centre Line of Nala as an 

open Polyline on this layer. Name 

of the poly should contain width 

of the Nala 

 

 R4 

_Net Plot No need to draw NETPLOT. This 

layer is not provided for PreDCR 

users... 

No need to give name 

on this layer. 

 

NPLT 

 

_NotInPossession  Plot area which is not in 

possession or which is not in 

proposal to be drawn as a closed 

polyline on this layer.  

 NIP  

_Parking  Draw a closed Polyline for 

Parking on “_Parking” Layer. You 

can also use Insert function to 

insert desired Parking Poly in 

your drawing. 

 

Insert-> Parking-

>Car-/ Scooter/ Cycle  

 

 PK 

_Passage 

  

Draw a closed polyline on 

“_Passage” Layer to represent 

passage with Centre Line (Ltype- 

Centerline) & single text inside it. 

 

 

 

Mark > Passage >  

Open Corridor 

Mark > 

Unmark(Default) 

PAS  

_PrintAdditionalDetail 

  

_PrintAdditionalDetail layer----

apart from the layers specified by 

PreDCR, any other information 
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which user wants to display in 

final approval print shall be 

drawn on _...this layer     

_Podium 

 

Draw a closed polyline on 

“_Podium” to represent Podium. It 

should be shown in the layout and 

not in floor plans 

  

  

 

 

POD  

_PropWork  PWork is a building profile and 

shall be drawn inside plot. Draw a 

closed polyline for Proposed 

Work on “_PropWork” Layer. 

  

Tools > Assign Name >  

Building and 

PropWork.  

 

  

 

PW  

_Ramp 

  

Draw a Ramp as a closed polyline 

with Centerline (L-type-Centre) & 

Text inside it in Plan. 

 

 

 

10.0m long 1.5m high 

Ramp 

 

RP 

_RecrationalGround  Description: - Draw Open space 

as closed polyline reserved as 

recreational space on this layer. 

With text on same layer. 

 

 

 

OPS 

_Refuge Area 

 

A closed polyline with Text 

around the refuge area should be 

 RFG 
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drawn on same Layer. 

Refuge area should be outside 

overlapped with FSI (ResiFSI, 

CommFSI) poly. 

_RefugeChute Draw closed polyline.   

_ResiFSI Draw a ResiFSI as a closed 

polyline which is the area 

covered by a building on all the 

floors. This FSI polyline only used 

for residential use bldg or floor. 

 

 

No need to give name 

on this layer. 

MFS 

_Right-Of-Way  Description: - Draw a closed 

polyline on “_Right-Of-Way” to 

represent a Right Of way and text 

inside it representing its width. 

Layer should be inside or 

intersecting with Plot poly.  

 ROW  

_Road Widening Road Acquisition/Road Widening 

area shall be drawn as a closed 

Polyline with Text on same layer 

inside Plot Entity. Margin will be 

generated & checked from Road 

widening Poly by AutoDCR 

software. 

 

 R5 

_Room A closed polyline for each room 

with its text inside should be 

drawn on this layer. Text should 

be given using <Assign Name> 

function 

 

 

Assign Name > Room 

RU 
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_Sewage line  Description: - Drain/Sewage 

Line: - Sewage line shall be drawn 

as an open polyline on this layer.  

 L5  

_Section Section poly should be drawn as a 

closed Polyline with Text on same 

Layer. It is used to group all 

Sectional detail like 

FloorInSection, Plinth, Stair cabin, 

Tank etc. 

(This is just a logical Group of 

Sectional Entity).  

(Note: Area or size of Floor 

doesn't have any meaning in 

AutoDCR) 

 

 SEC 

_Sanitation  Description: - Draw any 

sanitation entities on this layer. 

(E.g. Water closets, Kitchen sink 

etc...) Mark that entities by using 

PreDCR -> Insert -> Sanitation  

 SND  

_Site Plan 

 

The encapsulating poly around 

the Site/Key Plan with the Text & 

Scale inside it.  

 

 

 

 

STP 
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_Staircase Total Staircase area should be 

drawn as a closed polyline with 

text inside it. 

This Main Stair Poly should 

contain Intermediate Landing, 

Floor Landing & Each Tread as an 

open polyline. 

Intermediate & Floor Landing 

Poly can be Marked by PreDCR 

Tool "Mark>Staircase>Int. or 

Floor Landing" 

Mark->No of flight-

>3flight or 4 flight  

Mark-> Stair Case-> 

Fire Escape Staircase 

OR Fab/Spiral Stair 

  

Mark-> Staircase 

Landing-> Flight 

Width , Intermediate 

& Floor Landing 

STR 

_SpecialUseFSI A closed poly represents a other 

than Residential, commercial or 

Industrial use FSI or Floor FSI.  

It will cover whole area which is 

considered in FSI Area per Floor. 

 

 SUF 

_Substructure Substructures which are allowed 

in Margins or Layout & Free from 

FSI should be drawn as a closed 

polyline with text inside it. 

Name of the 

Substructure can be 

assigned from 

Mark>Substructure 

tool. 

SSTR 

_Tank Tank clear size should be drawn 

as a closed Polyline with Text on 

Assign Name>Tank   TNK 
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this Layer in Floor Plan or Plot as 

well as Section with same Text. 

(Note: It should be in proper 

Naming convention which is 

Provide by PreDCR by using Tool. 

 

_Terrace Closed polylines around the 

terraces to be drawn on this layer. 

If the terrace is used commonly 

by all tenements mark it as 

Common Terrace else it will be 

treated as Individual by default.  

 TER 

_Tree Description :  

Trees can be shown on _Tree 

layer if required to be shown for 

plantation requirement in plot. 

 

Insert - Tree  

_Ventilation Shaft Description: - Draw Ventilation 

shaft/duct area as a closed 

Polyline with Text. Inside FSI Area 

on _VentiShaft Layer. Only those 

shafts from which ventilation for 

habitable room is not taken should 

be drawn on this layer. 

 

 

AVS 

_Void If the space is not Chowk then it 

can be void. All ducts (where 

ventilation is not taken) and double 

height rooms can be drawn in void 

layer.  

 VD 
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_WaterLine Draw a open polyline on 

“_WaterLine” to represent water 

lines. 

 L4 

_Window Draw a closed polyline on 

_Window” Layer to represent 

window. You can also use Insert 

tool to insert window poly for 

particular size. 

Insert > window WND 

 

 

Specifications to be followed-  

The drawing entities should be drawn on Automatic layers created by using PreDCR. 

Plot layout, detailed floor plan and building section for all the floors should be there in one 

AutoCAD drawing file.   

All building items like proposed plot, proposed work, proposed parking etc must be drawn using 

closed polyline. 

(i.e. Every entity must be closed LWPOLYLINE except Railway Line , Drain line, Water Line, 

Electric Line, Dead Wall and Ground level.) 

Building Sub-Items must be exactly inside of outer closed polyline as per their place 

in architectural plan. 

This means none of the edge or vertex of inside entity should be drawn outside its container 

entity. For example Parking or Open Space poly must be exactly inside the main plot poly. Tools 

are provided in PreDCR to verify this check.  

Every Building Sub-Items should be given a specific/unique name (Text or MText entity) on the 

same layer & inside the entity poly. As far as possible, this name should be unique. If name not 

found then AutoDCR will generate the name automatically. Naming Conventions should be 

followed properly. 

e.g.  Each Room should be given the concerned name Using <Assign Name> function of PreDCR 

Living, Kitchen, Bedroom. Etc. Floor Name: GROUND FLOOR; TYPICAL FLOOR 1,2 & 5-8; 
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TERRACE FLOOR. Floor Items: Room Names should be given properly without using 

abbreviations so the software can identify perfect entity. This can be done by Assign name facility 

provided by the software. 

User shall use only following kind of entities for Building Items: -  

LWPOLYLINE / TEXT / MTEXT 

If in a plan two proposed work are mirrored in that case user should provide two separate 

building plan for each proposed work. 

 

Sample cases 

Residential Bldg (Row house) 

 

 

 Residential bldg. (Single Detached with two buildings) 
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Commercial building 

 

 

 Industrial Building 
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Special building (School bldg) 
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Meaning of various PreDCR Messages 

“Entity contain more than one text"  

      It means Entity on this layer contain more than one text. So remove the extra text. PreDCR 

need only one text for one entity. 

 

"Entity not contain any text"  

       It means this entity not having any name/text, so give the name to this   entity on this layer 

 

"Polyline is not in a proper format"  

        It means Highlighted polyline not drawn properly. So redraw that polyline & check the 

properties of that polyline. 

"Entity is not closed"  

       It means the highlighted entities not a closed polyline so close it by using 'pedit' command. 

 

"Entity is supposed to inside one of the following entities"  

       It means this highlighted entity should be present inside the one of the entities present in the 

given list“ 

 

"Entity is supposed to touching one of the following entities"  

      It means this highlighted entity is supposed to be touched one of the entities in given list 

 

"Entity should be outside overlapped with following entities“ 

      It means the highlighted entity should be outside overlapped with one of the th entities in the 

given list. 

“Entity must contain one of following entities“ 

      It means any one layer should be present inside in this entity which is listed. 

 

Following subentities are not found inside:  

     Direction Ref Point on layer _Floor, 

    Type: BLOCK, Color: ByLayer Status: 
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    Common Point on layer _ResiFSI, 

    Type: BLOCK, Color: ByLayer Status: 

    It means insert the direction reference circles in side of that entities. 

 

"The corresponding Building not found with same name"  

     It means that proposed work not having building with same name. So assigned that building 

with having same name of proposed work. 

"Mark Substructures using PreDCR mark Substructure tool"   

        It means mark the substructure by using mark -> Substructure menu.  Do not type 

substructure name manually. 

 

"The Lift machine room not found in building"  

        It means Lift machine room having name not same in Plan & in section. 

 

"The Lift poly is not suppose to be touch Lift machine room"  

        It means Lift machine room should be touch to lift poly in the section. 

 

 ‘Invalid objects, Please Try again"  

        It means if user marking balcony as a enclosed   but selecting layer of terrace then this 

message are getting. If selected entity is incorrect then invalid objects message are showing. So 

select correct layer for particular of that layer marking only 

"Section not found"  

      It means If all the floor plans are drawn but one of them in section floor are missing to 

converting floor in section layer then this message are getting. So draw all the floor plans with 

floor in sections. 

 

"The corresponding entities not found in section"  

      It means that listed entities not present in the section so show that entities in the section. 

 

"The corresponding entities not found in floor"  

      It means that listed entities not present in the floor so show that entities in the floor plan. 
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“Two Tanks should not have same Name” 

      It means that two tanks not having a same name. So assigned two tanks by using Assigned 

name PreDCR menu. 

 

Internal error or Fatal error while verify the drawing 

 Copy that file and paste it into the new drawing file & then verify. 

 

If Drawing is automatically closed / crashed while marking any entity or verify complete 

drawing. 

     Copy that file and paste it into the new drawing file & then verify. 

 

 

 

While   performing verification if following massage comes, then follow the steps  

Check each layer separately until you found problematic layer. After that those layers redraw.    
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13: System Requirement 

 

     Pentium IV or better (or compatible processor) 

         1 GB RAM (1 GB minimum) 

        Windows 98/2000/2007/XP    {32 bit & 64 bit}    

        CD-ROM drive 

       AutoCAD 2000 and onwards 

 

PreDCR & AutoDCR Settings for Windows Vista Operating System 

 Install  PreDCR &  AutoDCR   

 After Installation,  “Right Click” on Desktop Shortcut of  Predcr OR AutoDCR I con & click 
on “Properties”  

 Select “Compatibility” option from “PreDCR” OR “AutoDCR Properties” dialog. 

 In that, Select “Run this program in compatibility mode for:” (from Compatibility mode 
option) & select Windows XP/Windows XP (Service Pack 2) option from List. 
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 Click on “Apply” button & then click “OK” 

 
This is only one time changes. 
Now PreDCR OR AutoDCR will run fine in Windows Vista 
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